HomeTech NewsEXCEL E LA FUNZIONE ‘SE’

EXCEL E LA FUNZIONE ‘SE’

La funzione SE serve a confrontare i dati presenti in due celle e restituisce un determinato valore se il confronto ha esito positivo mentre ne restituisce un altro in caso di esito negativo.
Infatti la struttura delle formula e:

(test;se_vero;se_falso)

Mi spiego con due esempi.

Es. 1
=====

=SE(A1>A2;”buono”;”cattivo”)

In questo chiedo di confrontare il valore contenuto in a1 con quello contenuto in a2 (TEST).
Se a1 e’ maggiore di a2 (a1>a2) avro’ come risultato la parola “buono” (SE_VERO).
Se a1 e’ minore di a2 avro’ come risultato la parola cattivo (SE_FALSO).

Es. 2
=====

=SE(A1>A2;A3+A4;A5+A6)

Se a1 è maggiore di a2 (TEST), la formula mi eseguira’ l’operazione di somma dei valori contenuti nelle celle a3 e a4 (SE_VERO).
Viceversa se a1 e’ minore di a2 mi eseguirà la somma delle celle a5 e a6.

Nel primo caso un esito positivo del confronto fara’ visualizzare del testo (buono, cattivo).
Il testo che posso far visualizzare e’ naturalmente modificabile a piacere: basta inserirlo fra virgolette (” “).
Se invece non si vuole visualizzare niente, inserire solo le virgolette, senza spazi.

Nel secondo caso mi eseguira’ altre funzioni (a3+a4, a5+a6). Nel mio esempio le funzioni che verranno eseguite sono volutamente semplici.
Naturalmente si possono utuilizzare formule particolarmente complesse.

————————–

La funzione SE è nidificabile (fino a sette volte). Significa che io posso fare fino a sette test contemporaneamente. In questo modo posso soddisfare
piu’ condizioni.

Es. 3
=====

=SE(A1>A2;SE(A2>A3;”A2>A3″;”a3>A2″);”A2>A1”)

In questo caso chiedo di controllare se a1>a2. Se e’ vero chiedo di controllare che a2 sia maggiore di a3. Se anche questo e’ vero mi verra’ visualizzato il testo “a2>a3” (che si tratti di testo lo capiamo dalla
presenza delle virgolette). Se e’ falso mi verra’ visualizzato il testo “a3>a2”.

Se però A1 e’ minore di a2, il testo che mi viene visualizzato e’ “a2>a1″.

Lo schema della funzione e’ il seguente:

[test; se vero ->(test2; se vero; se falso); se falso]

Esercizio pratico
=================

Partendo da una colonna di numeri voglio che mi vengano visualizzati solo i numeri maggiori di 100 e minori di 200.

Nella prima colonna (A) inserisco i miei valori. Nella colonna (B) inserisco, nella prima riga, la seguente funzione:

=se(a1>100;se(a1<200;a1;””);””)

A questo punto seleziono la cella e la copio su tutta la colonna B.

Nella colonna B saranno visualizzati solo i valori compresi fra 100 e 200.

Autore

Nessun commento

Lascia un commento

Questo sito usa Akismet per ridurre lo spam. Scopri come i tuoi dati vengono elaborati.